RapidWeaver System Compatibility Notes

Follow

Comments

5 comments

  • Avatar
    The Beev

    I'm using Rapidweaver 6.4. Will it continue to work if I update my Mac to High Sierra?

  • Avatar
    Dan Counsell

    I'd recommend upgrading to RapidWeaver 7.x for High Sierra compatibility.

  • Avatar
    The Beev

    Hi Dan. Thanks for your reply. I fully understand that you would recommend upgrading. I don't actually use RW all that much. I can go months without needing to use it. I have been a user for quite some years and been through various upgrades. There are no features of RW 7 that I particularly want or need. The upgrade to RW 6 was for me an expensive disappointment, since nothing changed for me in terms of how the app works or the features that I use. I understand that you guys need to get paid for the work you do. I'm a developer myself, so of course I understand that. But are you able to see this from my point of view? Someone who doesn't use the app all that much, doesn't need bells and whistles, SEO, all this kind of stuff. I just want to know if the version I have will continue to function if I update to High Sierra. I know that if I buy this update, RW 8 will be along soon enough, and there will be some reason why I have to buy that too. I don't think it's right that I should be made to pay again and again for this app. It should be a choice. An informed choice.

  • Avatar
    Dan Counsell

    Understood!

    We've fully tested RW7 with High Sierra so I can guarantee it works, there were a few bugs and issues with RW6 under High Sierra so your mileage may vary. Maybe see how you get on.

    If you purchase the RW7 upgrade and we ship RW 8 within around the next 3 months, I'll give you a free upgrade (that's the timeframe we're aiming for).

    Or you could just use RW6 and jump straight to 8 when it ships, the choice is yours.

    Cheers
    Dan

  • Avatar
    The Beev

    Thanks very much for the quick reply. I'll take you up on that!

Please sign in to leave a comment.